Respondido

Router V5 - Port forward TCP e UDP


Boas.

Temos, para efeitos de teletrabalho, um setup que estava a funcionar na versão 4.0 do router. Após uma avaria deste foi-nos substituído por um da versão 5.

Acontece que temos no serviço VPN configurado, no servidor, uma VPN em UDP/1194 e outra em TCP/1194. Temos preferencia na utilização em UDP devido ao overhead mas há situações onde as redes são tão más que teremos de opcionalmente ir para o modo TCP.

O que acontece neste novo router é que se adicionar o port-forward TCP/1194 para o dispositivo depois não se consegue criar o UDP/1194 ou vice-versa - a interface devolve, erradamente, a informação que a porta já existe. Obviamente que não é verdade… a interface de configuração terá de verificar além do porto já existente numa configuração, se o protocolo é o mesmo…

Podia-se contornar o problema com a opção inexistente TCP+UDP.

E não, não é necessário PCMedics. Estamos cientes que o problema é mesmo a nível da interface e temos conhecimentos avançados de redes para saber isso mesmo.

icon

Melhor resposta por 0rangeFox 9 Dezembro 2020, 19:34

Boas.

Temos, para efeitos de teletrabalho, um setup que estava a funcionar na versão 4.0 do router. Após uma avaria deste foi-nos substituído por um da versão 5.

Acontece que temos no serviço VPN configurado, no servidor, uma VPN em UDP/1194 e outra em TCP/1194. Temos preferencia na utilização em UDP devido ao overhead mas há situações onde as redes são tão más que teremos de opcionalmente ir para o modo TCP.

O que acontece neste novo router é que se adicionar o port-forward TCP/1194 para o dispositivo depois não se consegue criar o UDP/1194 ou vice-versa - a interface devolve, erradamente, a informação que a porta já existe. Obviamente que não é verdade… a interface de configuração terá de verificar além do porto já existente numa configuração, se o protocolo é o mesmo…

Podia-se contornar o problema com a opção inexistente TCP+UDP.

E não, não é necessário PCMedics. Estamos cientes que o problema é mesmo a nível da interface e temos conhecimentos avançados de redes para saber isso mesmo.

Queres a solução para este tipo de problema? Está aqui o vídeo que explica como fazer isso num router de nOs através do painel aminhanet.nos.pt. 

 

Ver pergunta inicial

3 Comentários

Reputação 6
Crachá +2

Olá @ILC INSTITUTO LINGUAS CENTRO,

Para podermos ajudar, envie-nos, por favor, uma mensagem privada através do perfil @Fórum, com o seu número de cliente.

Obrigada

Boas.

Temos, para efeitos de teletrabalho, um setup que estava a funcionar na versão 4.0 do router. Após uma avaria deste foi-nos substituído por um da versão 5.

Acontece que temos no serviço VPN configurado, no servidor, uma VPN em UDP/1194 e outra em TCP/1194. Temos preferencia na utilização em UDP devido ao overhead mas há situações onde as redes são tão más que teremos de opcionalmente ir para o modo TCP.

O que acontece neste novo router é que se adicionar o port-forward TCP/1194 para o dispositivo depois não se consegue criar o UDP/1194 ou vice-versa - a interface devolve, erradamente, a informação que a porta já existe. Obviamente que não é verdade… a interface de configuração terá de verificar além do porto já existente numa configuração, se o protocolo é o mesmo…

Podia-se contornar o problema com a opção inexistente TCP+UDP.

E não, não é necessário PCMedics. Estamos cientes que o problema é mesmo a nível da interface e temos conhecimentos avançados de redes para saber isso mesmo.

Queres a solução para este tipo de problema? Está aqui o vídeo que explica como fazer isso num router de nOs através do painel aminhanet.nos.pt. 

 

Reputação 6
Crachá +2

Olá @0rangeFox,

Obrigada pela partilha. :relaxed:

Comentário